Forum uppdaterat till 3.3, samt PHP 7.4

Synpunkter och tips på förbundets nya hemsida

Moderators: boywing, pel, sestir, pem

Post Reply
User avatar
Eskil
Posts: 305
Joined: 14 May 2009, 10:10
Location: Göteborg
Contact:

Forum uppdaterat till 3.3, samt PHP 7.4

Post by Eskil »

Har nu uppdaterat forumet från version 3.2.8 till 3.3.0. Ändrade i samband med detta på webhotellets kontrollpanel så vi kör PHP version 7.4 ist för 7.1, då det krävdes en nyare PHP version för phpBB 3.3.0.

Det enda jag tror behövde göras, utöver standard update instruktioner, var att lägga in loggan i /forum/styles/prosilver/theme/images samt ändra i theme/common.css och theme/colours.css för att sätta rätt storlek och sökväg på loggan.

Verkar fungera fint, men meddela om något är konstigt. Backup finnes.

User avatar
Eskil
Posts: 305
Joined: 14 May 2009, 10:10
Location: Göteborg
Contact:

Re: Forum uppdaterat till 3.3, samt PHP 7.4

Post by Eskil »

EDIT: Ändrade från PHP 7.4 till PHP 7.3. Detta eftersom vid försök att uppdatera stockholms-drupal (version 8) med composer (enligt ) så fick jag fel där lösningen verkade vara att köra tidigare PHP än 7.4 (t.ex. https://www.drupal.org/forum/support/po ... ype-int-in). Detta verkar funka.

Med PHP 7.4:

Code: Select all

[goforbun@bandol stockholm]$ composer outdated "drupal/*"                                                    
  [ErrorException]                                    
  Trying to access array offset on value of type int  
show [--all] [-i|--installed] [-p|--platform] [-a|--available] [-s|--self] [-N|--name-only] [-P|--path] [-t|--tree] [-l|--latest] [-o|--outdated] [--ignore IGNORE] [-m|--minor-only] [-D|--direct] [--strict] [-f|--format FORMAT] [--] [<package>] [<version>]
Med PHP 7.3:

Code: Select all

[goforbun@bandol stockholm]$ composer outdated "drupal/*"
drupal/core                   8.9.1 9.0.2 Drupal is an open source content management platform powering millions of websites and applications.
drupal/core-composer-scaffold 8.9.0 9.0.2 A flexible Composer project scaffold builder.
drupal/core-project-message   8.9.0 9.0.2 Adds a message after Composer installation.
drupal/core-recommended       8.9.1 9.0.2 Locked core dependencies; require this project INSTEAD OF drupal/core.
drupal/core-vendor-hardening  8.9.0 9.0.2 Hardens the vendor directory for when it's in the docroot.
Så vi kör på PHP 7.3 tills vidare. Verkar funka bra med phpBB forum också.

Post Reply